[Midpoint-dev] Restrict user view to a particular Organisation Unit

Shelly Piplani shelly.piplani at ilantus.com
Mon Oct 6 23:32:01 CEST 2014

Hi ,

I am trying to restrict a user to view only one Organisation Unit to which he is a member of.

I am able to get the full organisation tree for a user but not able to restrict the user to view one OU
I tried different permutations and combinations for restricting the view of a store user to one particular organisation unit.

Following  is the script I tried to add in the role of that user:

<authorization id>
         <orgRef xmlns:tns="http://midpoint.evolveum.com/xml/ns/public/common/common-3"

Here oid=310f0079-4016-46e9-8a09-c9ed149a85a1 is the oid of the organisation Unit to which I want view for that user.

This script is not restricting the view to one Organisation Unit. However I am able to view the full Organisation tree for that user.

Please provide your help and advice on this.


This message contains information that may be privileged or confidential and is the property of ILANTUS Technologies. It is intended only for the person to whom it is addressed. If you are not the intended recipient, you are not authorized to read, print, retain, copy, disseminate, distribute, or use this message or any part thereof. If you receive this message in error, please notify the sender immediately and delete all copies of this message.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.evolveum.com/pipermail/midpoint-dev/attachments/20141006/ed6210bb/attachment.html>

More information about the midPoint-dev mailing list